できる気がしてきた。

僕の興味のあることを共有します。

linuxbrewでempty archiveなんていうエラーが出てきたら

linuxbrewを使って、早速emacsをインストールしようとウキウキしていたら、

==> Installing emacs
==> Downloading http://ftpmirror.gnu.org/emacs/emacs-24.5.tar.xz
==> Downloading from http://mirror.tochlab.net/pub/gnu/emacs/emacs-24.5.tar.xz
######################################################################## 100,0%

Error: Empty archive

となってしまい、うまくインストールできなかった。 これは、どうやら、Githubのissueに上がっているように、 アーカイバであるxzのバージョンが腐っているときに起きる現象らしい。

なので、brewを使ってxzのバージョンアップを行う。

$ brew reinstall xz

これでemacsが使える。めでたし。